Delimiter must not be alphanumeric or backslash错误的解决办法

2019年6月15日22:38:01 评论 233

php程序中之前一直使用split()函数,因新版本的php已经不支持split(),所以直接将split()更换为了preg_split(),运行时报:

Delimiter must not be alphanumeric or backslash

这是因为正则表达式没有加左右侧的斜线,你可以在正则表达式前后加 / ,尝试能否解决以上问题。

avatar
split()函数在PHP7中报错 系统教程

split()函数在PHP7中报错

在新版本的php中已经不再支持split() ,如果你原来的程序中使用了split() ,在新版本的php中将会报错。 split() 不建议使用的原因: PHP 5.3.0 之后的 regex, 希...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: