pip 升级到21.0.1 后报错 sys.stderr.write(f”ERROR: {exc}”)

2021年4月18日21:06:20 评论 1,000

新配置了一个环境,pip默认安装的为21.0.1,使用时直接报如下错误:

[root@duoluodeyu ~]# pip install qcloudapi-sdk-python
Traceback (most recent call last):
File "/usr/bin/pip", line 11, in <module>
load_entry_point('pip==21.0.1', 'console_scripts', 'pip')()
File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 561, in load_entry_point
File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2631, in load_entry_point
File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2291, in load
File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2297, in resolve
File "/usr/lib/python2.7/site-packages/pip-21.0.1-py2.7.egg/pip/_internal/cli/main.py", line 60
sys.stderr.write(f"ERROR: {exc}")
^
SyntaxError: invalid syntax

pip 升级到最近21.0.1 后报错 sys.stderr.write(f"ERROR: {exc}")

报错原因:

Python 2.7 已于2020年1月1日到期,请停止使用。请升级您的Python,因为不再维护Python 2.7。pip 21.0将于2021年1月停止对Python 2.7的支持。pip 21.0将删除对此功能的支持。

解决办法:

将pip降级,可以考虑降到pip 20.3.4版本。可执行下面两条指令:

wget https://bootstrap.pypa.io/pip/2.7/get-pip.py

python get-pip.py

pip 升级到21.0.1 后报错 sys.stderr.write(f"ERROR: {exc}")

avatar
WordPress默认屏蔽谷歌FLoC追踪技术 网站建设

WordPress默认屏蔽谷歌FLoC追踪技术

WordPress 今天发布公告,认为谷歌的新 FLoC 追踪技术存在安全隐患,并计划在 WordPress 网站上默认进行屏蔽。FLoC 全称叫做广告追踪技术群组联合学习,利用机器学习分析 Chro...
WordPress 5.3.1版本发布 业界动态

WordPress 5.3.1版本发布

来自WordPress官方的消息,WordPress 5.3.1版本发布,这是一个安全更新版本,也是一个常规更新维护版本。 WordPress 5.3.1一共修复46个漏洞或者漏洞相关安全问题。 官方...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: