WordPress 4.3及以上版本禁用修订版本及自动保存

2015年11月7日09:31:48 评论 720

WordPress升到最新版本后,更新文章或修改文章时发现Wordpress会自动保留很多的修订版本,这些版本在数据库中都会占用一条记录,对于使用post_id作为文章固定链接的站点,就会造成ID的严重不连续。为了确保ID尽可能的连续,我们需要禁用Wordpress的post_revision和autosave功能,Wordpress 4.3及以上版本禁用修订版本及自动保存的具体方法如下:

步骤一:编辑wp-config.php文件,在$table_prefix =  'wp_'; 前面添加下面的两行代码:

define('WP_POST_REVISIONS', false);//禁用post_revision
define('AUTOSAVE_INTERVAL', false);//禁用自动保存间隙时间

以上两行代码且不可放在wp-config.php文件最后面,放到最后起不到你所需要的作用。如你只需要禁用post_revision功能,仅添加第一行代码即可也无需执行步骤二。如你要禁用自动保存功能,请继续执行步骤二:

步骤二:编辑post-new.php文件,彻底禁用AUTOSAVE功能:

打开WordPress程序主目录下wp-admin目录下的post-new.php文件,在其中找到这行:

wp_enqueue_script(‘autosave’);

将其注释掉即可。PHP的注释可以使用两个斜杠(//),所以在上面那行代码的最前面输入两个斜杠,然后保存即可。

avatar
WordPress主题和插件添将支持自动更新功能 业界动态

WordPress主题和插件添将支持自动更新功能

WordPress 作为最流行的博客平台,有着丰富的扩展和主题生态系统。然而主题和扩展也经常成为 WordPress 网站的安全隐患,原因是网站管理人员在安装扩展或主题之后就不再更新。当扩展或主题发现...
WordPress 5.3.1版本发布 业界动态

WordPress 5.3.1版本发布

来自WordPress官方的消息,WordPress 5.3.1版本发布,这是一个安全更新版本,也是一个常规更新维护版本。 WordPress 5.3.1一共修复46个漏洞或者漏洞相关安全问题。 官方...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: